summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2010-04-14 17:00:31 -0400
committerEric S. Raymond <esr@thyrsus.com>2010-04-14 17:00:31 -0400
commitc933d2d200ce193c0a228cc9bda83a01c70ddef5 (patch)
tree4585d46582346046536be448cecdf94e3991b5dd /Makefile.am
parentb18615f502f0e3c52aa2fcaa570f3b4281998972 (diff)
downloadgpsd-c933d2d200ce193c0a228cc9bda83a01c70ddef5.tar.gz
Splint-clean gpxlogger.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index f2b1ca9b..ecd2ba5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -502,7 +502,9 @@ splint: gpsd.h packet_names.h
@echo "Running splint on gpspipe..."
-splint $(SPLINTOPTS) $(gpspipe_SOURCES)
@echo "Running splint on gpsdecode..."
- -splint $(SPLINTOPTS) -exportlocal gpsdecode.c
+ -splint $(SPLINTOPTS) $(gpsdecode_SOURCES)
+ @echo "Running splint on gpxlogger..."
+ -splint $(SPLINTOPTS) $(gpxlogger_SOURCES)
@echo "Running splint on test_bits test harness..."
-splint $(SPLINTOPTS) $(test_bits_SOURCES)
@echo "Running splint on test_packet test harness..."
@@ -518,11 +520,10 @@ splint: gpsd.h packet_names.h
cppcheck: gpsd.h packet_names.h
cppcheck --template gcc --all --force .
-# Re-indenting to a uniform style would be nice, and we leave this here
-# as a rough guide to the project style, but it turns out that indent is
-# an excessively blunt instrument.
+# Re-indent the codebase in aa uniform style for readability.
INDENT_FILES = $(gpsd_c_sources) $(libgpsd_c_sources) \
$(cgps_SOURCES) $(gpsmon_SOURCES) $(gpspipe_SOURCES) \
+ $(gpxlogger_SOURCES) $(xgpsspeed_SOURCES) $(gpsdecode_SOURCES) \
$(test_bits_SOURCES) $(test_packet_SOURCES) \
$(test_mkgmtime_SOURCES) $(test_geoid_SOURCES) $(test_json_SOURCES)
INDENT_OPTIONS = --indent-level4 \