summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGreg Troxel <gdt@ir.bbn.com>2009-12-04 20:51:25 +0000
committerGreg Troxel <gdt@ir.bbn.com>2009-12-04 20:51:25 +0000
commite50d3594271dfde3f3bbd203eb96cca642783cb1 (patch)
tree1b33ee121df48e6824a76a301f72db96fff9d611 /Makefile.am
parentb51f606e6ee2bb0da2199ba6b8f7ad4cac472146 (diff)
downloadgpsd-e50d3594271dfde3f3bbd203eb96cca642783cb1.tar.gz
trig test - not hooked into regress
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e04a1cf0..c4c89fe4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,7 +48,7 @@ endif
bin_PROGRAMS = $(MOTIF_PROGS) $(XAW_PROGS) $(RTCM104PROGS) $(CURSESPROGS) gpsctl gpspipe gpxlogger lcdgps
sbin_PROGRAMS = gpsd
-check_PROGRAMS = test_float test_bits test_packet test_mkgmtime test_geoid test_json
+check_PROGRAMS = test_float test_trig test_bits test_packet test_mkgmtime test_geoid test_json
if LIBGPSMM_ENABLE
check_PROGRAMS += test_gpsmm
endif
@@ -267,10 +267,10 @@ clean-local:
rm -rf build
if LIBGPSMM_ENABLE
-TESTBINS = test_float test_gpsmm test_bits test_packet test_geoid \
+TESTBINS = test_float test_trig test_gpsmm test_bits test_packet test_geoid \
test_mkgmtime test_json
else
-TESTBINS = test_float test_bits test_packet test_geoid \
+TESTBINS = test_float test_trig test_bits test_packet test_geoid \
test_mkgmtime test_json
endif
@@ -280,6 +280,12 @@ endif
test_float_SOURCES = test_float.c
test_float_LDADD = $(LIBC) libgps.la -lm
+#
+# Build test_trig
+#
+test_trig_SOURCES = test_trig.c
+test_trig_LDADD = $(LIBC) libgps.la -lm
+
if LIBGPSMM_ENABLE
#
# Build test_gpsmm
@@ -401,6 +407,7 @@ EXTRA_DIST = \
maskaudit.py.in \
dgpsip-servers \
test_float.c \
+ test_trig.c \
gpsd.php \
gpsd.xml \
gpsd.h-head \