summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2007-12-05 10:18:40 +0000
committerEric S. Raymond <esr@thyrsus.com>2007-12-05 10:18:40 +0000
commite67fcadfb1b456540a7d8e03bcb0bd0f883f3818 (patch)
tree3d3b3676689afa5787172814d836260be6295952 /Makefile.am
parent5303fb5854363b04796e05a63a217ddb9b6216b1 (diff)
downloadgpsd-e67fcadfb1b456540a7d8e03bcb0bd0f883f3818.tar.gz
Enable clean build when Python is not present.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9f8a670a..450a98b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -172,9 +172,8 @@ libgps_la_LIBADD = $(LIBM) $(LIBC) $(LIBNSL) $(LIBSOCKET) $(LIBPTHREAD)
# install may require --root depending on what you're doing.
# python setup.py install --root=$DESTIR --prefix=$PREFIX
if HAVE_PYTHON
-PYEXTENSIONS = gpspacket.so
-
-noinst_SCRIPTS = gpspacket.so setup.py
+@HAVE_PYTHON_TRUE@PYEXTENSIONS = gpspacket.so
+@HAVE_PYTHON_TRUE@noinst_SCRIPTS = gpspacket.so setup.py
gpspacket.so: gpspacket.c libgps.la
(pwd="`pwd`"; cd $(srcdir) && $(PYTHON) setup.py build_ext --build-lib "$$pwd" --build-temp "$$pwd/build" --include-dirs "$$pwd")