summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2011-01-13 10:41:15 -0500
committerEric S. Raymond <esr@thyrsus.com>2011-01-13 10:41:15 -0500
commitec08b6848939dc66b378ecd9789e33f27f915ff9 (patch)
treef32512e4880646db1ba86d4c6a17ca243096e46c /Makefile.am
parentc93c46f0c10e56b52d3c980e7082ab74f7003f66 (diff)
downloadgpsd-ec08b6848939dc66b378ecd9789e33f27f915ff9.tar.gz
More deheader testing. All regressions pass, codebase splints clean.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 25652ac5..d7cfa6d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -649,9 +649,10 @@ xmllint: $(XML)
# Use deheader to remove headers not required. If the statistics line
# ends with other than '0 removed' there's work to be done.
ENABLES = -DDEBUG -DPPS_ENABLE -DRAW_ENABLE
+NOHEADCHECK = -x 'cpp' -x 'contrib' -x 'gpspacket.c' -x 'gpsclient.c' -x 'monitor_proto.c'
deheader:
- make --quiet clean gpsd.h packet_names.h
- deheader -x 'cpp' -i gpsd_config.h -i gpsd.h -m "MORECFLAGS='-Werror -Wfatal-errors $(ENABLES)' make -e"
+ make --quiet clean $(BUILT_SOURCES)
+ deheader $(NOHEADCHECK) -i gpsd_config.h -i gpsd.h -m "MORECFLAGS='-Werror -Wfatal-errors $(ENABLES)' make -e"
make --quiet clean
# Re-indent the codebase in a uniform style for readability.