summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2011-01-19 16:13:21 -0500
committerEric S. Raymond <esr@thyrsus.com>2011-01-19 16:13:21 -0500
commitf6a463bd47b8f3149a9fdba5e02383ae1bc4e4da (patch)
treefcdd6cee9a0ecf757fe02263c925b86fbb50cd95 /Makefile.am
parent181a455552c3274c29f789b7cba1cd5185261b1f (diff)
downloadgpsd-f6a463bd47b8f3149a9fdba5e02383ae1bc4e4da.tar.gz
Generate coefficients for least-squares fit into the C code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 78915549..93e9e2e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -209,7 +209,7 @@ libgpsd_h_sources = \
libgpsd_la_LDFLAGS = $(LIBUSB_LIBS) $(BLUEZ_LIBS)
-BUILT_SOURCES = packet_names.h gpsd.h revision.h ais_json.i gps_maskdump.c gpsd_maskdump.c
+BUILT_SOURCES = packet_names.h gpsd.h revision.h ais_json.i gps_maskdump.c gpsd_maskdump.c leapcheck.h
packet_names.h: packet_states.h
rm -f packet_names.h && \
@@ -244,14 +244,17 @@ gpsd_maskdump.c: gpsd.h maskaudit.py
$(PYTHON) maskaudit.py -d >gpsd_maskdump.c && \
chmod a-w gpsd_maskdump.c
+leapcheck.h: leapsecond.py #leapcheck.i
+ $(PYTHON) leapsecond.py -h leapcheck.i >leapcheck.h
+
# This gets kept in the repo so we can build without Internet access
leapcheck.i: leapsecond.py
- $(PYTHON) leapsecond.py -c leapcheck.i
+ $(PYTHON) leapsecond.py -f leapcheck.i
libgps_la_SOURCES = $(libgps_c_sources)
libgpsd_la_SOURCES = $(libgpsd_c_sources) $(libgpsd_h_sources) \
- driver_rtcm2.h packet_states.h
+ driver_rtcm2.h packet_states.h leapcheck.h
# Warning: This overrides autoconf's normal link-line generation process
if LIBGPSMM_ENABLE