summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGreg Troxel <gdt@ir.bbn.com>2010-12-18 11:22:46 -0500
committerGreg Troxel <gdt@ir.bbn.com>2010-12-18 12:12:52 -0500
commitf9e500d9a3892a125ad1d41b633c5b10f847929d (patch)
treeb49b4180a962fb9bf11fb67559d88371a6d0f6a3 /Makefile.am
parentda828804f27b1c774cb4d0a31e4737d84b569f8b (diff)
downloadgpsd-f9e500d9a3892a125ad1d41b633c5b10f847929d.tar.gz
Link test_bits with bits.o instead of libgpsd.
Without this, test_bits fails to link due to undefined gpsd_report(). >From Beat Bolli on gpsd-dev@.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4d0f727f..a42c354e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -434,7 +434,7 @@ endif
# Build test_bits tester
#
test_bits_SOURCES = test_bits.c
-test_bits_LDADD = $(LIBC) libgpsd.la libgps.la $(LIBUSB_LIBS)
+test_bits_LDADD = $(LIBC) bits.o libgps.la $(LIBUSB_LIBS)
#
# Build packets tester