summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2009-09-29 21:14:34 +0000
committerEric S. Raymond <esr@thyrsus.com>2009-09-29 21:14:34 +0000
commitff752029df033c16591f6a1556f03d2ce4bf7229 (patch)
tree3da4cb2ec7e9ce53584b6a60215531ad4157179d /Makefile.am
parent9fbf47a10a244ac08eda2510df48659e2e2d87f8 (diff)
downloadgpsd-ff752029df033c16591f6a1556f03d2ce4bf7229.tar.gz
Add some debugging machinery - we can now dump set flags in a convenient form.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 13243920..3539ea3a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -149,6 +149,7 @@ libgpsd_c_sources = \
libgps_json.c \
gpsdclient.c \
libgpsd_core.c \
+ maskdump.c \
net_dgpsip.c \
net_gnss_dispatch.c \
net_ntrip.c \
@@ -184,7 +185,7 @@ libgpsd_h_sources = \
bits.h \
crc24q.h
-BUILT_SOURCES = packet_names.h gpsd.h ais_json.i
+BUILT_SOURCES = packet_names.h gpsd.h ais_json.i maskdump.c
packet_names.h: packet_states.h
rm -f $(srcdir)/packet_names.h
@@ -205,6 +206,11 @@ ais_json.i: jsongen.py
$(srcdir)/jsongen.py --ais --target=parser >ais_json.i
chmod a-w $(srcdir)/ais_json.i
+maskdump.c: gpsd.h-tail devtools/maskaudit
+ rm -f $(srcdir)/maskdump.c
+ $(srcdir)/devtools/maskaudit -c >maskdump.c
+ chmod a-w $(srcdir)/maskdump.c
+
libgps_la_SOURCES = $(libgpsd_c_sources) $(libgpsd_h_sources) \
driver_rtcm2.h libgpsmm.cpp packet_states.h
nodist_libgps_la_SOURCES = packet_names.h ais_json.i