summaryrefslogtreecommitdiff
path: root/SConstruct
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2011-08-26 15:39:53 -0400
committerEric S. Raymond <esr@thyrsus.com>2011-08-26 15:39:53 -0400
commitaf6c53acaebf996a35b90eec94a033be9138856c (patch)
tree46c2f86d1a0bf6013d99f5ce247a8d460b90cbf6 /SConstruct
parent0c764a77789ecef2904261db20340e9739cd3d5d (diff)
downloadgpsd-af6c53acaebf996a35b90eec94a033be9138856c.tar.gz
Slightly improved cleanup production.
Diffstat (limited to 'SConstruct')
-rw-r--r--SConstruct2
1 files changed, 1 insertions, 1 deletions
diff --git a/SConstruct b/SConstruct
index 3eb9dea2..b6e2bf4a 100644
--- a/SConstruct
+++ b/SConstruct
@@ -958,7 +958,7 @@ if manbuilder:
## Where it all comes together
build = env.Alias('build', [libraries, binaries, python_built_extensions, manpage_targets])
-env.Clean(build, glob.glob("*.o") + glob.glob("*.os"))
+env.Clean(build, map(glob.glob, ("*.o", "*.os", "*.os.*", "*.a")) + ["packaging/rpm/gpsd.spec"])
env.Default(*build)
if qt_env: