summaryrefslogtreecommitdiff
path: root/SConstruct
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2011-04-12 00:17:17 -0400
committerEric S. Raymond <esr@thyrsus.com>2011-04-12 00:17:17 -0400
commitd3c8319984ff8c9aca4cf27619e64146a48faa37 (patch)
tree4000281df6e32a6da6eec0c69692f8ce3f85c959 /SConstruct
parent144ff3823d7158a8ac79e82ea31f71c7a62234c2 (diff)
downloadgpsd-d3c8319984ff8c9aca4cf27619e64146a48faa37.tar.gz
Fix tarballs to have a proper version prefix.
Diffstat (limited to 'SConstruct')
-rw-r--r--SConstruct4
1 files changed, 2 insertions, 2 deletions
diff --git a/SConstruct b/SConstruct
index 6d818a60..b2c41906 100644
--- a/SConstruct
+++ b/SConstruct
@@ -724,7 +724,7 @@ python_manpages = {
manpage_targets = []
if manbuilder:
- for (man, xml) in base_manpages.items():
+ for (man, xml) in base_manpages.items() + python_manpages.items():
manpage_targets.append(env.Man(source=xml, target=man))
## Where it all comes together
@@ -1077,7 +1077,7 @@ if os.path.exists("gpsd.c") and os.path.exists(".gitignore"):
distfiles.append("packaging/rpm/gpsd.spec")
dist = env.Command('dist', distfiles, [
- '@tar -czf gpsd-${VERSION}.tar.gz $SOURCES',
+ '@tar --transform "s:^:gpsd-${VERSION}/:" -czf gpsd-${VERSION}.tar.gz $SOURCES',
'@ls -l gpsd-${VERSION}.tar.gz',
])
env.Clean(dist, "gpsd-${VERSION}.tar.gz")