summaryrefslogtreecommitdiff
path: root/SConstruct
diff options
context:
space:
mode:
authorFred Wright <fw@fwright.net>2018-12-23 18:48:50 -0800
committerFred Wright <fw@fwright.net>2018-12-23 18:54:50 -0800
commitda4a2b80309c541df26637d585a04acb346ec4e5 (patch)
tree3b4d1eefc37cfedb783ffdbfe110d4c949ff032b /SConstruct
parentffff77fd94cb5612339215caae3c2edc55def84d (diff)
downloadgpsd-da4a2b80309c541df26637d585a04acb346ec4e5.tar.gz
Fixes symlink handling in zip target.
By default, zip follows symlinks rather than storing them as links in the archive. This resulted in redundant copies of the 'gps' subdirectory, which not only wasted space, but also wouldn't actually work in practice since they wouldn't get populated with the build products. Adding the 'y' option to the zip invocation fixes this. TESTED: Verified that the resulting zip archive has the expected symlinks, and that the content matches the repo.
Diffstat (limited to 'SConstruct')
-rw-r--r--SConstruct2
1 files changed, 1 insertions, 1 deletions
diff --git a/SConstruct b/SConstruct
index 76d67a06..c0256e5d 100644
--- a/SConstruct
+++ b/SConstruct
@@ -2585,7 +2585,7 @@ if os.path.exists("gpsd.c") and os.path.exists(".gitignore"):
# How to build a zip file.
zip = env.Command('zip', distfiles, [
- '@zip -r gpsd-${VERSION}.zip $SOURCES',
+ '@zip -ry gpsd-${VERSION}.zip $SOURCES',
'@ls -l gpsd-${VERSION}.zip',
])
env.Clean(zip, ["gpsd-${VERSION}.zip", "packaging/rpm/gpsd.spec"])