summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2006-08-16 20:10:38 +0000
committerEric S. Raymond <esr@thyrsus.com>2006-08-16 20:10:38 +0000
commit186bc439db1cf3d38b6ed428d6cd5d328872ddbe (patch)
treedb7fe8f9cdc31db84c69cb3b4c7163fc8211f127 /configure.ac
parent06d965e8fee9c44ca8f2badd71d397fb7f4c15b9 (diff)
downloadgpsd-186bc439db1cf3d38b6ed428d6cd5d328872ddbe.tar.gz
Introduce NTRIP configuration option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 503a3b27..d4416829 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,6 +282,21 @@ fi
AM_CONDITIONAL([HAVE_RTCM104], [test "$ac_rtcm104" = "yes"])
+dnl check for NTRIP support
+AC_ARG_ENABLE(ntrip,
+ AC_HELP_STRING([--disable-ntrip],
+ [disable NTRIP support]),
+ [ac_ntrip=$enableval], [ac_ntrip=yes])
+AC_MSG_CHECKING([for NTRIP support])
+if test x"$ac_ntrip" = "xyes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([NTRIP_ENABLE], 1, [NTRIP support])
+else
+ AC_MSG_RESULT([no])
+fi
+
+AM_CONDITIONAL([HAVE_NTRIP], [test "$ac_ntrip" = "yes"])
+
dnl check for profiling support
AC_ARG_ENABLE(profiling,
AC_HELP_STRING([--enable-profiling],
@@ -449,6 +464,7 @@ echo "Garmin : $ac_garmin"
echo "True North : $ac_tnt"
echo "Evermore : $ac_evermore"
echo "RTCM104 support : $ac_rtcm104"
+echo "NTRIP support : $ac_ntrip"
echo "NTP SHM : $ac_ntpshm"
echo "NTP PPS : $ac_pps"
echo "Fixed port speed : $ac_baud"