summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2005-02-14 12:53:04 +0000
committerEric S. Raymond <esr@thyrsus.com>2005-02-14 12:53:04 +0000
commit27dda86c0151647e1d64397d1ffb292a303fa7bf (patch)
tree1492764bc9915e9b4706adcab3f4be64cdff9aee /configure.ac
parent8a22a9e672d1f313ba65054bf7d5037c28a2811e (diff)
downloadgpsd-27dda86c0151647e1d64397d1ffb292a303fa7bf.tar.gz
Integrate first-cut Garmin binary driver.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3dcca67d..3a5cebc7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,19 @@ else
AC_MSG_RESULT([no])
fi
+dnl check for Garmin support
+AC_ARG_ENABLE(garmin,
+ AC_HELP_STRING([--disable-garmin],
+ [disable DeLorme Garmin Garmin support]),
+ [ac_garmin=$enableval], [ac_garmin=yes])
+AC_MSG_CHECKING([for Garmin support])
+if test x"$ac_garmin" = "xyes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([GARMIN_ENABLE], 1, [Garmin support])
+else
+ AC_MSG_RESULT([no])
+fi
+
dnl check for Logfile support
AC_ARG_ENABLE(logfile,
AC_HELP_STRING([--disable-logfile],
@@ -168,6 +181,7 @@ echo "------------------------------------------"
echo "FV-18 : $ac_fv18"
echo "Tripmate : $ac_tripmate"
echo "Earthmate : $ac_earthmate"
+echo "Garmin : $ac_garmin"
echo "Logfile : $ac_logfile"
echo "Enable shared libraries : $enable_shared"
echo "Profiling : $ac_profiling"