summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Kuethe <chris.kuethe@gmail.com>2006-12-15 05:13:32 +0000
committerChris Kuethe <chris.kuethe@gmail.com>2006-12-15 05:13:32 +0000
commit344f11dca17028ae98a96732cf96b143add6946e (patch)
treef29ab84c077058c1db813e9d1224874ebf703802 /configure.ac
parentff65bffdc2416bca7d66367b33a57b73734da003 (diff)
downloadgpsd-344f11dca17028ae98a96732cf96b143add6946e.tar.gz
add a --enable-gpsd-user configure option.
if unspecified, gpsd will retain its current behaviour: dropping to "nobody".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f6b4b56..2ceb023e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -405,6 +405,19 @@ else
AC_MSG_RESULT([no])
fi
+dnl check for privilege revokation user at compile-time
+AC_ARG_ENABLE(gpsd-user,
+ AC_HELP_STRING([--enable-gpsd-user=username],
+ [GPSD privilege revokation user]),
+ [ac_user=$enableval], [ac_user=nobody])
+AC_MSG_CHECKING([privilege revokation user])
+if test x"$ac_user" != "xnobody"; then
+ AC_MSG_RESULT([$ac_user])
+ AC_DEFINE_UNQUOTED([GPSD_USER], "$ac_user", [GPSD privilege revokation user])
+else
+ AC_MSG_RESULT([nobody])
+fi
+
dnl check for port speed fixed at compile-time
AC_ARG_ENABLE(fixed-port-speed,
AC_HELP_STRING([--enable-fixed-port-speed=nnn],