summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2009-09-29 03:49:36 +0000
committerEric S. Raymond <esr@thyrsus.com>2009-09-29 03:49:36 +0000
commit3d35659c4c9c85f363a165eedb6ffefb256477a2 (patch)
tree679b14ad50da57f8d7f61002dc8b59d1144ec7a4 /configure.ac
parentb5f3674f36a32c38caa569fb3afc90d02c54fb90 (diff)
downloadgpsd-3d35659c4c9c85f363a165eedb6ffefb256477a2.tar.gz
Rip out most of the old profiling support.
Replace it with a new, lighter- weight version that can be configured out.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5f07a063..413db375 100644
--- a/configure.ac
+++ b/configure.ac
@@ -675,6 +675,19 @@ else
AC_MSG_RESULT([no])
fi
+dnl check for latency timing support
+AC_ARG_ENABLE(timing,
+ AC_HELP_STRING([--disable-timing],
+ [disable latency timing support]),
+ [ac_timing=$enableval], [ac_timing=yes])
+AC_MSG_CHECKING([for latency timing support])
+if test x"$ac_timing" = "xyes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([TIMING_ENABLE], 1, [latency timing support)])
+else
+ AC_MSG_RESULT([no])
+fi
+
dnl check for support for oldstyle protocol
AC_ARG_ENABLE(oldstyle,
AC_HELP_STRING([--disable-oldstyle],
@@ -991,6 +1004,7 @@ echo "OceanServer : $ac_oceanserver"
echo "UBX : $ac_ubx"
echo "GPSclock : $ac_gpsclock"
echo "AIVDM support : $ac_aivdm"
+echo "Timing support : $ac_timing"
echo "MKT-3301 : $ac_mkt3301"
dnl Below this line are non-protocol switches
echo " Daemon Features"