summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBernd Zeimetz <bernd@bzed.de>2010-05-10 15:01:00 +0200
committerBernd Zeimetz <bernd@bzed.de>2010-05-10 15:01:00 +0200
commit458745ebd16df0350d09bfe991a4a851537b159d (patch)
tree55c4eb114ad0177d219e1ee134102b574370f81c /configure.ac
parentc348dbdb04843b452664427c36e666997d0e0dcd (diff)
parent24c90d66542abf973b4a0058ca3b25e6130b8dc8 (diff)
downloadgpsd-458745ebd16df0350d09bfe991a4a851537b159d.tar.gz
Merge branch 'new-xgpsspeed'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac64
1 files changed, 0 insertions, 64 deletions
diff --git a/configure.ac b/configure.ac
index ca729ac0..1f304e13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -304,70 +304,6 @@ else
fi
AM_CONDITIONAL([HAVE_QT], [test x"$ac_qt" = xyes])
-dnl Check for X libraries
-ac_x="no"
-if test x"$with_x" != "xno" -a x"$have_x" != "xdisabled"
- then
- X_LIBS=-lX11
- AC_CHECK_HEADERS(X11/xpm.h xpm.h)
- if test x"$ac_cv_header_X11_xpm_h" = "xno" &&
- test x"$ac_cv_header_xpm_h" = "xno"; then
- AC_MSG_WARN([xpm.h problem - xgpsspeed won't be built.])
- fi
- AC_PATH_XTRA
- if test x"$ac_cv_have_x" = "xno"; then
- AC_MSG_WARN([X problem - xgps won't be built.])
- fi
- LIBS="$LIBS $X_EXTRA_LIBS"
- CFLAGS="$CFLAGS $X_CFLAGS"
- CPPFLAGS="$CPPFLAGS $X_CFLAGS"
- AC_SUBST(X_LIBS)
- AC_SUBST(X11_LIBS)
- AC_SUBST(X_PRE_LIBS)
-
- dnl Check for some auxiliary X libraries we'll need
- AC_CHECK_LIB(Xt, XtToolkitInitialize, XT_LIBS="-lXt",,
- ${X_PRE_LIBS} ${X11_LIBS})
- AC_SUBST(XT_LIBS)
- if test x"$ac_cv_lib_Xt_XtToolkitInitialize" = "xno"; then
- AC_MSG_WARN([libXt problem - xgps won't be built.])
- fi
- dnl We can't use AC_SEARCH_LIBS because it always modifies LIBS.
- dnl Instead, check for two common places (xorg way and the
- dnl traditional way) by hand.
- AC_CHECK_LIB(Xaw8, XawInitializeWidgetSet, XAW_LIBS="-lXaw8",
- AC_CHECK_LIB(Xaw7, XawInitializeWidgetSet, XAW_LIBS="-lXaw7",
- AC_CHECK_LIB(Xaw, XawInitializeWidgetSet, XAW_LIBS="-lXaw",
- ,${X_PRE_LIBS} ${X11_LIBS}),
- ${X_PRE_LIBS} ${X11_LIBS}),
- ${X_PRE_LIBS} ${X11_LIBS})
- AC_SUBST(XAW_LIBS)
- if test x"$XAW_LIBS" = "x"; then
- AC_MSG_WARN([libXaw problem - xgpsspeed won't be built.])
- AM_CONDITIONAL([HAVE_XAW],false)
- else
- AM_CONDITIONAL([HAVE_XAW],true)
- fi
- AC_CHECK_LIB(Xext, XShapeQueryVersion, XEXT_LIBS="-lXext",,
- ${X_PRE_LIBS} ${X11_LIBS})
- AC_SUBST(XEXT_LIBS)
- if test x"$ac_cv_lib_Xext_XShapeQueryVersion" = "xno"; then
- AC_MSG_WARN([libXext problem - xgpsspeed won't be built.])
- fi
- AC_CHECK_LIB(Xpm, XpmCreatePixmapFromXpmImage,
- XPM_LIBS="-lXpm"
- AC_DEFINE([HAVE_XPM],1,[Xpm available]),,${X_PRE_LIBS} ${X11_LIBS})
- AC_SUBST(XPM_LIBS)
- if test x"$ac_cv_lib_Xpm_XpmCreatePixmapFromXpmImage" = "xno"; then
- AC_MSG_WARN([libXpm problem - xgpsspeed won't be built.])
- fi
-else
- dnl X11 disabled
- AM_CONDITIONAL([HAVE_XAW],false)
- AC_MSG_WARN([Not including X11 support])
-fi
-dnl End of X11 checks
-
dnl Check for curses headers and libraries. The presence of the
dnl library is used to decide whether or not to build some programs.
dnl Those programs use ncurses.h if found, and otherwise use curses.h.