summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2009-11-20 14:28:38 +0000
committerEric S. Raymond <esr@thyrsus.com>2009-11-20 14:28:38 +0000
commit6b6a5d59bb6a2189404fb8b525d20b191a0e0977 (patch)
tree46a72ba3f80d4821da04de04806ce8618a589273 /configure.ac
parent560c63feaf6bc550da65e370a8b58214556a7c0a (diff)
downloadgpsd-6b6a5d59bb6a2189404fb8b525d20b191a0e0977.tar.gz
Client library debugging can now nbe enabled at runtime.
That is, if the CLIENTDEBUG_ENABLE feature switch is on. All regression tests pass.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 13675554..dd087caa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -691,6 +691,21 @@ else
AC_MSG_RESULT([no])
fi
+dnl check for client debugging support
+AC_ARG_ENABLE(clientdebug,
+ AC_HELP_STRING([--disable-clientdebug],
+ [disable client debugging support]),
+ [ac_clientdebug=$enableval], [ac_clientdebug=yes])
+AC_MSG_CHECKING([for client debugging support])
+if test x"$ac_clientdebug" = "xyes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([CLIENTDEBUG_ENABLE], 1, [client debugging support)])
+else
+ AC_MSG_RESULT([no])
+fi
+
+AM_CONDITIONAL([CLIENTDEBUG_ENABLE], [test x"$ac_clientdebug" = x"yes"])
+
dnl check for support for oldstyle protocol
AC_ARG_ENABLE(oldstyle,
AC_HELP_STRING([--disable-oldstyle],
@@ -1031,6 +1046,7 @@ echo "UBX : $ac_ubx"
echo "GPSclock : $ac_gpsclock"
echo "AIVDM support : $ac_aivdm"
echo "Timing support : $ac_timing"
+echo "Client debugging support: $ac_clientdebug"
echo "MTK-3301 : $ac_mtk3301"
dnl Below this line are non-protocol switches
echo " Daemon Features"