summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2005-05-11 19:43:10 +0000
committerEric S. Raymond <esr@thyrsus.com>2005-05-11 19:43:10 +0000
commit7284e3167f58730f224c939c29e06657f6a1078f (patch)
tree795608fbe8fb286d796705457355f87ad7a0a43b /configure.ac
parent5e814ccc8fae6da4dca2bf32da6297a687e94d47 (diff)
downloadgpsd-7284e3167f58730f224c939c29e06657f6a1078f.tar.gz
First cut at PPS support (conditioned on --enable-pps).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 40d13db6..abbee883 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,6 +207,19 @@ else
AC_MSG_RESULT([no])
fi
+dnl check for PPS time syncing support
+AC_ARG_ENABLE(pps,
+ AC_HELP_STRING([--enable-pps],
+ [enable PPS time syncing support]),
+ [ac_pps=$enableval], [ac_pps=no])
+AC_MSG_CHECKING([for PPS time syncing support])
+if test x"$ac_pps" = "xyes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([PPS_ENABLE], 1, [PPS time syncing support])
+else
+ AC_MSG_RESULT([no])
+fi
+
AC_OUTPUT(Makefile gpsd.spec)
dnl Output the configuration summary
@@ -219,6 +232,7 @@ echo "Tripmate : $ac_tripmate"
echo "Earthmate : $ac_earthmate"
echo "Garmin : $ac_garmin"
echo "NTP SHM : $ac_ntpshm"
+echo "NTP PPS : $ac_pps"
echo "Enable shared libraries : $enable_shared"
echo "------------------------------------------"
echo "Configure finished, type 'make' to build."