summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBernd Zeimetz <bernd@bzed.de>2010-05-10 14:50:41 +0200
committerBernd Zeimetz <bernd@bzed.de>2010-05-10 14:50:41 +0200
commit739b83a7db9bc6c0e0d8f5a313995c8a5ae445eb (patch)
treead9093bafdb924ce0567215c03749ec9a6116e39 /configure.ac
parente0e26538ab0d39a875a19ae81dd755f91ff531d8 (diff)
downloadgpsd-739b83a7db9bc6c0e0d8f5a313995c8a5ae445eb.tar.gz
Replacing xgpsspeed with the new version written in Python.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac64
1 files changed, 0 insertions, 64 deletions
diff --git a/configure.ac b/configure.ac
index 69c4f2b0..9b161901 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,70 +288,6 @@ size_t strlcpy(/*@out@*/char *dst, /*@in@*/const char *src, size_t size);
#define GPSD_CONFIG_H])
-dnl Check for X libraries
-ac_x="no"
-if test x"$with_x" != "xno" -a x"$have_x" != "xdisabled"
- then
- X_LIBS=-lX11
- AC_CHECK_HEADERS(X11/xpm.h xpm.h)
- if test x"$ac_cv_header_X11_xpm_h" = "xno" &&
- test x"$ac_cv_header_xpm_h" = "xno"; then
- AC_MSG_WARN([xpm.h problem - xgpsspeed won't be built.])
- fi
- AC_PATH_XTRA
- if test x"$ac_cv_have_x" = "xno"; then
- AC_MSG_WARN([X problem - xgps won't be built.])
- fi
- LIBS="$LIBS $X_EXTRA_LIBS"
- CFLAGS="$CFLAGS $X_CFLAGS"
- CPPFLAGS="$CPPFLAGS $X_CFLAGS"
- AC_SUBST(X_LIBS)
- AC_SUBST(X11_LIBS)
- AC_SUBST(X_PRE_LIBS)
-
- dnl Check for some auxiliary X libraries we'll need
- AC_CHECK_LIB(Xt, XtToolkitInitialize, XT_LIBS="-lXt",,
- ${X_PRE_LIBS} ${X11_LIBS})
- AC_SUBST(XT_LIBS)
- if test x"$ac_cv_lib_Xt_XtToolkitInitialize" = "xno"; then
- AC_MSG_WARN([libXt problem - xgps won't be built.])
- fi
- dnl We can't use AC_SEARCH_LIBS because it always modifies LIBS.
- dnl Instead, check for two common places (xorg way and the
- dnl traditional way) by hand.
- AC_CHECK_LIB(Xaw8, XawInitializeWidgetSet, XAW_LIBS="-lXaw8",
- AC_CHECK_LIB(Xaw7, XawInitializeWidgetSet, XAW_LIBS="-lXaw7",
- AC_CHECK_LIB(Xaw, XawInitializeWidgetSet, XAW_LIBS="-lXaw",
- ,${X_PRE_LIBS} ${X11_LIBS}),
- ${X_PRE_LIBS} ${X11_LIBS}),
- ${X_PRE_LIBS} ${X11_LIBS})
- AC_SUBST(XAW_LIBS)
- if test x"$XAW_LIBS" = "x"; then
- AC_MSG_WARN([libXaw problem - xgpsspeed won't be built.])
- AM_CONDITIONAL([HAVE_XAW],false)
- else
- AM_CONDITIONAL([HAVE_XAW],true)
- fi
- AC_CHECK_LIB(Xext, XShapeQueryVersion, XEXT_LIBS="-lXext",,
- ${X_PRE_LIBS} ${X11_LIBS})
- AC_SUBST(XEXT_LIBS)
- if test x"$ac_cv_lib_Xext_XShapeQueryVersion" = "xno"; then
- AC_MSG_WARN([libXext problem - xgpsspeed won't be built.])
- fi
- AC_CHECK_LIB(Xpm, XpmCreatePixmapFromXpmImage,
- XPM_LIBS="-lXpm"
- AC_DEFINE([HAVE_XPM],1,[Xpm available]),,${X_PRE_LIBS} ${X11_LIBS})
- AC_SUBST(XPM_LIBS)
- if test x"$ac_cv_lib_Xpm_XpmCreatePixmapFromXpmImage" = "xno"; then
- AC_MSG_WARN([libXpm problem - xgpsspeed won't be built.])
- fi
-else
- dnl X11 disabled
- AM_CONDITIONAL([HAVE_XAW],false)
- AC_MSG_WARN([Not including X11 support])
-fi
-dnl End of X11 checks
-
dnl Check for curses headers and libraries. The presence of the
dnl library is used to decide whether or not to build some programs.
dnl Those programs use ncurses.h if found, and otherwise use curses.h.