summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2009-03-06 14:55:03 +0000
committerEric S. Raymond <esr@thyrsus.com>2009-03-06 14:55:03 +0000
commit80f9bdade8fd0565eaa885b6683c4a27437a7091 (patch)
tree5f4c3618a4a95ffc821c0a2d86786429fbaf02ef /configure.ac
parentb00632ab81f8532200a69f79fbb9b369ae3302ad (diff)
downloadgpsd-80f9bdade8fd0565eaa885b6683c4a27437a7091.tar.gz
Support --disable-controlsend
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 087e711b..2cc3d3f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -684,7 +684,7 @@ else
AC_MSG_RESULT([no])
fi
-dnl check for privilege revokation user at compile-time
+dnl check for privilege revocation user at compile-time
AC_ARG_ENABLE(gpsd-user,
AC_HELP_STRING([--enable-gpsd-user=username],
[GPSD privilege revokation user]),
@@ -776,6 +776,19 @@ else
AC_MSG_RESULT([no])
fi
+dnl allow tools to use control_send method
+AC_ARG_ENABLE(controlsend,
+ AC_HELP_STRING([--disable-controlsend],
+ [do not allow gpsd to change device settings]),
+ [ac_controlsend=$enableval], [ac_controlsend=yes])
+AC_MSG_CHECKING([if control sending is allowed])
+if test x"$ac_controlsend" != "xno"; then
+ AC_MSG_RESULT([$ac_controlsend])
+ AC_DEFINE([ALLOW_CONTROLSEND], 1, [Allow gpsd to controlsend device])
+else
+ AC_MSG_RESULT([no])
+fi
+
dnl Automatic check for DBUS.
dnl It's broken -- leads to bad compiles on systems with DBUS libraies
dnl but no DBUS headers.
@@ -912,6 +925,7 @@ echo "Enable Python support : $ac_python"
echo "Limited max clients : $ac_maxclients"
echo "Limited max devices : $ac_maxdevices"
echo "Allow device reconfig : $ac_reconfigure"
+echo "Allow control send : $ac_controlsend"
echo "Squelch logging/hexdump : $ac_squelch"
echo "Build ncurses programs : $ac_ncurses"
echo "------------------------------------------"