summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGreg Troxel <gdt@ir.bbn.com>2009-01-10 19:54:03 +0000
committerGreg Troxel <gdt@ir.bbn.com>2009-01-10 19:54:03 +0000
commit9702d1995eb4e9787245f79b8b0c9134b4d40636 (patch)
tree98d6dc310cacdb6495c07dc62c9c7991f8a9adc4 /configure.ac
parent52462846e9dc198543ce07c88c31aa5e69391cbb (diff)
downloadgpsd-9702d1995eb4e9787245f79b8b0c9134b4d40636.tar.gz
In addition to Xaw and Xaw8, also look for and accept Xaw7.
Found on pkgsrc with modular xorg.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d5dae5df..d3f027cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -200,7 +200,10 @@ if test x"$with_x" != "xno" -a x"$have_x" != "xdisabled"
dnl Instead, check for two common places (xorg way and the
dnl traditional way) by hand.
AC_CHECK_LIB(Xaw, XawInitializeWidgetSet, XAW_LIBS="-lXaw",
- AC_CHECK_LIB(Xaw8, XawInitializeWidgetSet, XAW_LIBS="-lXaw8",,${X_PRE_LIBS} ${X11_LIBS}),
+ AC_CHECK_LIB(Xaw8, XawInitializeWidgetSet, XAW_LIBS="-lXaw8",
+ AC_CHECK_LIB(Xaw7, XawInitializeWidgetSet, XAW_LIBS="-lXaw7",
+ ,${X_PRE_LIBS} ${X11_LIBS}),
+ ${X_PRE_LIBS} ${X11_LIBS}),
${X_PRE_LIBS} ${X11_LIBS})
AC_SUBST(XAW_LIBS)
if test x"$XAW_LIBS" = "x"; then