summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2009-11-11 07:38:49 +0000
committerEric S. Raymond <esr@thyrsus.com>2009-11-11 07:38:49 +0000
commit9e8952cceb1522fbc47cfafea1d172c89e276c34 (patch)
tree56803567591357cbffb2c6bcf76faf6a38a253e6 /configure.ac
parent7d7c0070f109bdae92df7e0c2b4fa12b53a664b9 (diff)
downloadgpsd-9e8952cceb1522fbc47cfafea1d172c89e276c34.tar.gz
Enable option to condition out C++ support in libgps.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dd0f9bb3..2991e042 100644
--- a/configure.ac
+++ b/configure.ac
@@ -925,6 +925,21 @@ else
AC_MSG_RESULT([no])
fi
+dnl C++ bindings
+AC_ARG_ENABLE(libgpsmm,
+ AC_HELP_STRING([--disable-libgpsmm],
+ [don't build C++ bindings]),
+ [ac_libgpsmm=$enableval], [ac_libgpsmm=yes])
+AC_MSG_CHECKING([for C++ support])
+if test x"$ac_libgpsmm" = "xyes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([LIBGPSMM_ENABLE], 1, [C++ support])
+else
+ AC_MSG_RESULT([no])
+fi
+
+AM_CONDITIONAL([LIBGPSMM_ENABLE], [test x"$ac_libgpsmm" = x"yes"])
+
dnl Test for XSLT processor (xsltproc or xmlto)
AC_CHECK_PROG(WITH_XSLTPROC,[xsltproc],[yes],[no])
MANGENERATOR=
@@ -1023,6 +1038,7 @@ echo "Limited max devices : $ac_maxdevices"
echo "Allow device reconfig : $ac_reconfigure"
echo "Allow control send : $ac_controlsend"
echo "Squelch logging/hexdump : $ac_squelch"
+echo "C++ binding : $ac_libgpsmm"
echo "Raw Measurements : $ac_raw"
echo " Client Features"
echo " ---------------"