summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Kuethe <chris.kuethe@gmail.com>2006-12-15 06:53:43 +0000
committerChris Kuethe <chris.kuethe@gmail.com>2006-12-15 06:53:43 +0000
commitccc954b862eb21fae5df8f08f6a06fd4cc5e06c9 (patch)
treee14e36501d98be17c5f478720f10532786df7f4e /configure.ac
parent75060d26715ecb280deeb730e8d952b9398f5183 (diff)
downloadgpsd-ccc954b862eb21fae5df8f08f6a06fd4cc5e06c9.tar.gz
The start of a UBX driver, from Andreas Stricker. Not yet
functional but committed to allow for in-tree development.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 559f793f..36677d6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -307,6 +307,19 @@ else
AC_MSG_RESULT([no])
fi
+dnl check for UBX support
+AC_ARG_ENABLE(ubx,
+ AC_HELP_STRING([--enable-ubx],
+ [enable UBX Protocol support]),
+ [ac_ubx=$enableval], [ac_ubx=no])
+AC_MSG_CHECKING([for UBX support])
+if test x"$ac_ubx" = "xyes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([UBX_ENABLE], 1, [UBX Protocol support])
+else
+ AC_MSG_RESULT([no])
+fi
+
dnl check for EverMore support
AC_ARG_ENABLE(evermore,
AC_HELP_STRING([--disable-evermore],
@@ -594,6 +607,7 @@ echo "iTrax : $ac_itrax"
echo "iTalk : $ac_italk"
echo "Navcom : $ac_navcom"
echo "Garmin : $ac_garmin"
+echo "UBX : $ac_ubx"
echo "True North : $ac_tnt"
echo "EverMore : $ac_evermore"
echo "RTCM104 support : $ac_rtcm104"
@@ -622,6 +636,7 @@ if test x"$ac_nmea" = "xno" -a \
x"$ac_italk" = "xno" -a \
x"$ac_navcom" = "xno" -a \
x"$ac_garmin" = "xno" -a \
+ x"$ac_ubx" = "xno" -a \
x"$ac_evermore" = "xno"; then
AC_MSG_ERROR(Can't build gpsd with no protocols enabled)
fi