summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2006-12-15 23:09:27 +0000
committerEric S. Raymond <esr@thyrsus.com>2006-12-15 23:09:27 +0000
commitd5c7fbc2967e2561c474512d341a2884e8f644a3 (patch)
tree10ef287ab43fe619c6496b7b77653f7ddf033d58 /configure.ac
parentd1bfbecaba3d841a5d9ab0cf28792ed146d93d3d (diff)
downloadgpsd-d5c7fbc2967e2561c474512d341a2884e8f644a3.tar.gz
Degrade the build gracefully if pthreads are not present.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 415b1858..261e96c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,7 +85,7 @@ AC_CHECK_LIB(m, rint, LIBM="-lm")
AC_SUBST(LIBM)
AC_CHECK_LIB(c, open, LIBC="-lc")
AC_SUBST(LIBC)
-AC_CHECK_LIB(pthread, main, LIBPTHREAD="-lpthread")
+AC_CHECK_LIB(pthread, main, LIBPTHREAD="-lpthread", ac_pthreads='yes', ac_pthreads='no')
AC_SUBST(LIBPTHREAD)
AH_VERBATIM([_GNU_SOURCE],
@@ -401,7 +401,7 @@ AC_ARG_ENABLE(pps,
[disable PPS time syncing support]),
[ac_pps=$enableval], [ac_pps=yes])
AC_MSG_CHECKING([for PPS time syncing support])
-if test x"$ac_pps" = "xyes"; then
+if test x"$ac_pthreads" = xyes -a x"$ac_pps" = "xyes"; then
AC_MSG_RESULT([yes])
AC_DEFINE([PPS_ENABLE], 1, [PPS time syncing support])
else