summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Browet <cbro@semperpax.com>2010-03-31 04:35:58 -0400
committerEric S. Raymond <esr@thyrsus.com>2010-03-31 04:35:58 -0400
commitd8462cfb9ef84e1b0fbd7c794993318d56bd6dfc (patch)
tree4ef0f2990e1d5e63d89c8361a57e7231252153df /configure.ac
parent3202783122582a67b82ff40507550a17dffebb74 (diff)
downloadgpsd-d8462cfb9ef84e1b0fbd7c794993318d56bd6dfc.tar.gz
Internals of Qt support.
All regression tests pass. Note from esr: this feature cannot be announced yert, as it requires documentation in the INSTALL file. 1. What the target environments are (Linux? Windows? Both) 2. All build prerequisites (C++ compiler? Qt library? Other libraries?) 3. What the new files libQgpsmm_global.h and libQgpsmm.pro are for, and how the are used. We also need to know how to regression-test this code under Linux so we can verify that it's not broken as the client library evolves. Signed-off-by: Eric S. Raymond <esr@thyrsus.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 082ea20c..e1c30fa3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,10 +231,22 @@ AC_SUBST(LIBPTHREAD)
AH_VERBATIM([_GNU_SOURCE],
[/* Some libc's don't have strlcat/strlcpy. Local copies are provided */
#ifndef HAVE_STRLCAT
+# ifdef __cplusplus
+extern "C" {
+# endif
size_t strlcat(/*@out@*/char *dst, /*@in@*/const char *src, size_t size);
+# ifdef __cplusplus
+}
+# endif
#endif
#ifndef HAVE_STRLCPY
+# ifdef __cplusplus
+extern "C" {
+# endif
size_t strlcpy(/*@out@*/char *dst, /*@in@*/const char *src, size_t size);
+# ifdef __cplusplus
+}
+# endif
#endif
#define GPSD_CONFIG_H])