summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Kuethe <ckuethe@users.berlios.de>2010-12-02 10:11:53 -0800
committerChris Kuethe <ckuethe@users.berlios.de>2010-12-02 10:11:53 -0800
commitd9b5e1610339a3bb91a52561188a5b6c70f1e2a4 (patch)
treefdab10ef5262e64f2e7323679df4f4b0342bdb75 /configure.ac
parentb72450ec75e9e9552503667a557945cc18d41139 (diff)
downloadgpsd-d9b5e1610339a3bb91a52561188a5b6c70f1e2a4.tar.gz
Somehow the geostar bit got lost
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5b278ce6..1df5d3e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -507,6 +507,19 @@ else
AC_MSG_RESULT([no])
fi
+dnl check for Geostar support
+AC_ARG_ENABLE(geostar,
+ AC_HELP_STRING([--disable-geostar],
+ [disable Geostar Protocol support]),
+ [ac_geostar=$enableval], [ac_geostar=yes])
+AC_MSG_CHECKING([for Geostar support])
+if test x"$ac_geostar" = "xyes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([GEOSTAR_ENABLE], 1, [Geostar Protocol support])
+else
+ AC_MSG_RESULT([no])
+fi
+
dnl check for EverMore support
AC_ARG_ENABLE(evermore,
AC_HELP_STRING([--disable-evermore],
@@ -1049,6 +1062,7 @@ echo "EverMore : $ac_evermore"
echo "FV-18 : $ac_fv18"
echo "Garmin : $ac_garmin"
echo "Garmin Simple Text : $ac_garmintxt"
+echo "Geostar : $ac_geostar"
echo "iTrax : $ac_itrax"
echo "NMEA : $ac_nmea"
echo "NTRIP : $ac_ntrip"
@@ -1103,6 +1117,7 @@ if test "xdummy" = "xdummy" -a \
x"$ac_fv18" = "xno" -a \
x"$ac_garmin" = "xno" -a \
x"$ac_garmintxt" = "xno" -a \
+ x"$ac_geostar" = "xno" -a \
x"$ac_itrax" = "xno" -a \
x"$ac_navcom" = "xno" -a \
x"$ac_nmea" = "xno" -a \