summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2005-07-11 13:42:36 +0000
committerEric S. Raymond <esr@thyrsus.com>2005-07-11 13:42:36 +0000
commitec431ba52ff66b8f2f25fb865913dd2616bcc5d1 (patch)
tree8325d430f497b6535af51245814197bbc08da673 /configure.ac
parent93dd4d46bf2d242e4dcd759b6584f8f65d82c99b (diff)
downloadgpsd-ec431ba52ff66b8f2f25fb865913dd2616bcc5d1.tar.gz
Configure DBUS correctly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 44c1faad..6c1c0dac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -305,7 +305,6 @@ if test x"yes" = x"$ac_cv_lib_dbus_1_dbus_bus_get" ; then
if test x"ac_dbus" = x"yes" ; then
AC_DEFINE([DBUS_ENABLE],1,[Found DBUS libraries])
fi
- AM_CONDITIONAL([HAVE_DBUS], [test x"$ac_dbus" = x"yes"])
# Check for glib and dbus-glib, used by gpxlogger
PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.2.0 )
@@ -316,6 +315,7 @@ if test x"yes" = x"$ac_cv_lib_dbus_1_dbus_bus_get" ; then
AC_SUBST(DBUS_GLIB_CFLAGS)
AC_SUBST(DBUS_GLIB_LIBS)
fi
+AM_CONDITIONAL([HAVE_DBUS], [test x"$ac_dbus" = x"yes"])
AC_OUTPUT(Makefile contrib/Makefile gpsd.spec)