summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2007-03-27 11:58:49 +0000
committerEric S. Raymond <esr@thyrsus.com>2007-03-27 11:58:49 +0000
commitf25cc4c6f4a442f505cb84bc670bf7f328a98ca7 (patch)
tree1d7fe477e376ebcfa73d0e316507d326b2f0e3d0 /configure.ac
parent13c3eb1ca0fd303a9dc88d70a6f80b356c421818 (diff)
downloadgpsd-f25cc4c6f4a442f505cb84bc670bf7f328a98ca7.tar.gz
Matt Roberds sent these changes to make configure more explicit...
...when the X clients cannot be built for some reason.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 22 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7eac827f..253b6236 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,7 +166,14 @@ ac_x="no"
if test x"$with_x" != xno && test x"$have_x" != xdisabled
then
AC_CHECK_HEADERS(X11/xpm.h xpm.h)
+if test x"$ac_cv_header_X11_xpm_h" = "xno" &&
+ test x"$ac_cv_header_xpm_h" = "xno"; then
+ AC_MSG_WARN([xpm.h problem - xgps won't be built.])
+fi
AC_PATH_XTRA
+if test x"$ac_cv_have_x" = "xno"; then
+ AC_MSG_WARN([X problem - xgps won't be built.])
+fi
LIBS="$LIBS $X_EXTRA_LIBS"
CFLAGS="$CFLAGS $X_CFLAGS"
CPPFLAGS="$CPPFLAGS $X_CFLAGS"
@@ -179,17 +186,29 @@ dnl Check for some auxiliary X libraries we'll need
AC_CHECK_LIB(Xt, XtToolkitInitialize, XT_LIBS="-lXt",,
${X_PRE_LIBS} ${X11_LIBS})
AC_SUBST(XT_LIBS)
+if test x"$ac_cv_lib_Xt_XtToolkitInitialize" = "xno"; then
+ AC_MSG_WARN([libXt problem - xgps won't be built.])
+fi
AC_CHECK_HEADER([X11/Xaw/Label.h],, motif_includes="no")
AC_CHECK_LIB(Xaw, XawInitializeWidgetSet, XAW_LIBS="-lXaw",,
${X_PRE_LIBS} ${X11_LIBS})
AC_SUBST(XAW_LIBS)
+if test x"$ac_cv_lib_Xaw_XawInitializeWidgetSet" = "xno"; then
+ AC_MSG_WARN([libXaw problem - xgps won't be built.])
+fi
AC_CHECK_LIB(Xext, XShapeQueryVersion, XEXT_LIBS="-lXext",,
${X_PRE_LIBS} ${X11_LIBS})
AC_SUBST(XEXT_LIBS)
+if test x"$ac_cv_lib_Xext_XShapeQueryVersion" = "xno"; then
+ AC_MSG_WARN([libXext problem - xgps won't be built.])
+fi
AC_CHECK_LIB(Xpm, XpmCreatePixmapFromXpmImage,
XPM_LIBS="-lXpm"
AC_DEFINE([HAVE_XPM],1,[Xpm available]),,${X_PRE_LIBS} ${X11_LIBS})
AC_SUBST(XPM_LIBS)
+if test x"$ac_cv_lib_Xpm_XpmCreatePixmapFromXpmImage" = "xno"; then
+ AC_MSG_WARN([libXpm problem - xgps won't be built.])
+fi
dnl Check for Motif widget libraries
XM_LIBS=""
@@ -212,8 +231,9 @@ AC_SUBST(XM_LIBS)
AM_CONDITIONAL([HAVE_MOTIF], [test "$XM_LIBS" != "" -a "$motif_includes" != "no"])
ac_x="yes"
else
-dnl X11 disabled
-AM_CONDITIONAL([HAVE_MOTIF], [test "motif" = "no"])
+ dnl X11 disabled
+ AM_CONDITIONAL([HAVE_MOTIF], [test "motif" = "no"])
+ AC_MSG_WARN([general X problem - xgps won't be built.])
fi
dnl End of X11 checks