summaryrefslogtreecommitdiff
path: root/gpsd.ebuild
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2006-11-11 07:17:59 +0000
committerEric S. Raymond <esr@thyrsus.com>2006-11-11 07:17:59 +0000
commit500825f1f2ff39735a92f4b8f62db2d9607194f9 (patch)
tree79cc5bb24d16d2be389cfcf8610b24081503a883 /gpsd.ebuild
parentd3093d47a305d1f50e5527f28e76ea0bfb660802 (diff)
downloadgpsd-500825f1f2ff39735a92f4b8f62db2d9607194f9.tar.gz
Move the Gentoo ebuild into the repo.
Update the web page and the welcome to vendors with the new stuff about IRC channels and PHP status pages. Clean up the site-update machinery. Add build-time dependencies on xsltproc and python to the spec file.
Diffstat (limited to 'gpsd.ebuild')
-rw-r--r--gpsd.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/gpsd.ebuild b/gpsd.ebuild
new file mode 100644
index 00000000..f589f155
--- /dev/null
+++ b/gpsd.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2005 Amaury Jacquot
+# Author: Amaury Jacquot <sxpert@esitcom.org>
+
+DESCRIPTION="gpsd is a daemon that listens to a GPS or Loran receiver and
+translates the positional data into a simplified format that can be more easily
+used by other programs like chart plotters. The package comes with a sample
+client that plots the location of the currently visible GPS satellites (if
+available) and a speedometer. It can also use DGPS/ip, and run as a DGPS/ip
+server, and, if the PPS signal is available, be used for NTP synchronization"
+HOMEPAGE="http://gpsd.berlios.de"
+SRC_URI="http://download.berlios.de/gpsd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64 alpha"
+
+IUSE="motif"
+DEPEND="motif? (=x11-libs/openmotif)"
+
+src_compile() {
+ econf \
+ $(use_with motif x) \
+ || die "econf failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install
+}