summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2011-01-29 01:04:23 -0500
committerEric S. Raymond <esr@thyrsus.com>2011-01-29 01:04:23 -0500
commit24b81d753d98564767ce5af11ae5730791e4ab08 (patch)
treec67dd640dd1dcc4c45b456f32dce97f3db852336 /setup.py
parent6d28ed6d07ab3ec92351acea296ed4b984f94db7 (diff)
downloadgpsd-24b81d753d98564767ce5af11ae5730791e4ab08.tar.gz
Fix minor bug in 'clean' mode.
It had been introduced by a change to support out-of-directory builds. All regression tests pass.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 53625eb3..dfb0199d 100644
--- a/setup.py
+++ b/setup.py
@@ -35,8 +35,8 @@ if not manpages:
print("No XML processor, omitting manual-page installation.")
MAKE = ("MAKE" in os.environ) and os.environ["MAKE"] or "make"
+abs_builddir = ("abs_builddir" in os.environ) and os.environ["abs_builddir"] or ""
if not 'clean' in sys.argv:
- abs_builddir = ("abs_builddir" in os.environ) and os.environ["abs_builddir"] or ""
if not os.path.exists(os.path.join(abs_builddir, 'gpsd_config.h')):
sys.stderr.write('\nPlease run configure first!\n')
sys.exit(1)