summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2006-12-04 19:04:28 +0000
committerEric S. Raymond <esr@thyrsus.com>2006-12-04 19:04:28 +0000
commit28a92bdce0bfb2da046e9d5fa47511d7c3054399 (patch)
tree90bb816b7e5a3f908c8cc594d7983e231885a147 /setup.py
parentf057cf1fa3095056370f5dd39af2a8ec3b0ce38c (diff)
downloadgpsd-28a92bdce0bfb2da046e9d5fa47511d7c3054399.tar.gz
First cut at a Python binding for the packet.c module.
It builds and imports without errors, but has not been tested yet.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..e3b871f9
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,6 @@
+# Creates build/lib.linux-${arch}-${pyvers}/gpspacket.so,
+# where ${arch} is an architecture and ${pyvers} is a Python version.
+from distutils.core import setup, Extension
+setup(name="gpspacket", version="1.0",
+ ext_modules=[Extension("gpspacket",
+ ["gpspacket.c", "isgps.c", "rtcm.c", "strl.c", "hex.c"])])