summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBernd Zeimetz <bernd@bzed.de>2010-04-16 01:18:39 +0200
committerBernd Zeimetz <bernd@bzed.de>2010-04-16 01:18:39 +0200
commita7b39ee92ab32385a7985f26906b6055a74074fd (patch)
treecc21c77f46fa23f6a8f6fb587b63be024f711953 /setup.py
parent032f3fa180e4943346b94c5fe23651173d03c5f9 (diff)
downloadgpsd-a7b39ee92ab32385a7985f26906b6055a74074fd.tar.gz
Use setup.py to install python scripts.
This ensures that the shebang in the scripts is being updated to the Python version which was used to run setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index fe518232..f686d8f5 100644
--- a/setup.py
+++ b/setup.py
@@ -63,5 +63,6 @@ setup( name="gpsd",
Extension("gps.client", ["gpsclient.c", "geoid.c", "gpsdclient.c", "strl.c"])
],
packages = ['gps'],
- data_files=[('bin', ['gpscat','gpsfake','gpsprof'])] + manpages
+ scripts = ['gpscat','gpsfake','gpsprof', 'xgps'],
+ data_files= manpages
)