summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2009-11-07 16:41:33 +0000
committerEric S. Raymond <esr@thyrsus.com>2009-11-07 16:41:33 +0000
commite4a3cf40056a01c459bbe7e3e4f3e9e68ff846e7 (patch)
treef9f56148f20d43f796f186490cf0d2e25d9216f6 /setup.py
parentb8640c1a2cf6dff7a5c9053051afb2d0ce1b9c69 (diff)
downloadgpsd-e4a3cf40056a01c459bbe7e3e4f3e9e68ff846e7.tar.gz
Previous setup.py fix mysteriously didn't work. Adding instrumentation.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e9ef81d7..e0c0fdcc 100644
--- a/setup.py
+++ b/setup.py
@@ -24,8 +24,11 @@ try:
# Doesn't matter what it is, just that we have one
if sys.argv[where+1]:
manpages=[('share/man/man1', ['gpscat.1', 'gpsfake.1','gpsprof.1'])]
+ print "Installing manual pages, generator is", sys.argv[where+1]
sys.argv = sys.argv[:where] + sys.argv[where+2:]
except ValueError:
+ pass
+if not manpages:
print "No XML processor, omitting manual-page installation."
if not 'clean' in sys.argv: