summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..048c691
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,38 @@
+# Process this file with automake to create Makefile.in
+# Makefile.am for grep/doc.
+#
+# Copyright 2008-2016 Free Software Foundation, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+info_TEXINFOS = grep.texi
+grep_TEXINFOS = fdl.texi
+
+man_MANS = grep.1 fgrep.1 egrep.1
+
+EXTRA_DIST = grep.in.1
+CLEANFILES = grep.1 egrep.1 fgrep.1
+
+grep.1: grep.in.1
+ $(AM_V_GEN)rm -f $@-t $@
+ $(AM_V_at)sed 's/@''VERSION@/$(VERSION)/' $(srcdir)/grep.in.1 > $@-t
+ $(AM_V_at)chmod a=r $@-t
+ $(AM_V_at)mv -f $@-t $@
+
+egrep.1 fgrep.1: Makefile.am
+ $(AM_V_GEN)rm -f $@-t $@
+ $(AM_V_at)inst=`echo grep | sed '$(transform)'`.1 \
+ && echo ".so man1/$$inst" > $@-t
+ $(AM_V_at)chmod a=r $@-t
+ $(AM_V_at)mv -f $@-t $@