summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8a20317e..0dd4d849 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,6 +206,12 @@ fi
gl_FUNC_PCRE
+gl_PRINTF_SIZES_C99
+if test "$gl_cv_func_printf_sizes_c99" = yes; then
+ AC_DEFINE([HAVE_PRINTF_C99_SIZES], [1],
+ [Define to 1 if printf formats %j, %z, %t and %L work.])
+fi
+
case $host_os in
mingw*) suffix=w32 ;;
*) suffix=posix ;;