summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBertrand Garrigues <bertrand.garrigues@laposte.net>2018-03-27 23:34:06 +0200
committerBertrand Garrigues <bertrand.garrigues@laposte.net>2018-03-28 00:50:48 +0200
commit00156d87619530e6807a55c27e8965b74762690f (patch)
treec939f5289ffca243c5f716f2618faca279d49b7c /Makefile.am
parent1ae2a7c644f60ea7897cf29dbf0c8fd7d8cbac76 (diff)
downloadgroff-git-00156d87619530e6807a55c27e8965b74762690f.tar.gz
Define a short version for data installation dir name.1.22.4.rc2
This is the full version stripped of any characters after the third digit. Used for installation of font, macro and various data (by default in /usr/local/share/groff). The various programs and scripts still use the full version from gnulib script 'git-version-gen' . * configure.ac (SHORT_VERSION): short version definition. * Makefile.am: use 'SHORT_VERSION' for 'docdir' and 'datasubdir' definitions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7cc50f6f8..6a05cca88 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,7 +154,7 @@ TTYDEVDIRS=@TTYDEVDIRS@ font/devutf8
# datadir
# datarootdir
dataprogramdir=$(datadir)/groff
-datasubdir=$(dataprogramdir)/$(VERSION)
+datasubdir=$(dataprogramdir)/$(SHORT_VERSION)
# infodir
# `infodir' says where to install info files.
@@ -162,7 +162,7 @@ datasubdir=$(dataprogramdir)/$(VERSION)
# docdir
# `docdir' says where to install documentation files. The default
# location is ${datarootdir}/doc/${PACKAGE}, but we add the version
-docdir=$(datarootdir)/doc/${PACKAGE}-$(VERSION)
+docdir=$(datarootdir)/doc/${PACKAGE}-$(SHORT_VERSION)
# `exampledir' says where to install example files.
exampledir=$(docdir)/examples
@@ -633,6 +633,11 @@ endif
#
# REVISION is the full revision given by git-version-gen, which can
# have non-alphanumeric symbols.
+#
+# SHORT_REVISION contains only the number of REVISION before the first
+# '.', e.g. if REVISION is '3.real.434-5aafd' then SHORT_REVISION is
+# '3'.
+
MAJOR_VERSION =`echo $(VERSION) | sed 's/\([0-9]\+\)\.[0-9]\+.*/\1/'`
MINOR_VERSION =`echo $(VERSION) | sed 's/[0-9]\+\.\([0-9]\+\).*/\1/'`
REVISION = `echo $(VERSION) | sed 's/[0-9]\+\.[0-9]\+\.\(.*\)/\1/'`
@@ -770,7 +775,7 @@ install-data-hook: create_current_symlink
create_current_symlink:
cd $(DESTDIR)$(dataprogramdir); \
rm -f current; \
- $(LN_S) $(VERSION) current
+ $(LN_S) $(SHORT_VERSION) current
# Hook to move the binaries that potentially have a prefix from
# prefixexecbindir to bindir.