summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-06-03 14:04:52 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-06-03 14:36:47 -0500
commit21b21cfc9e4830ee559f20aff270d151c2f1b44c (patch)
tree342a28df441a667689994241e2d799e7466a5b02 /Makefile.am
parent67ba5f333b5b7e2cb6dca8e411208725a2e0d705 (diff)
downloadgroff-git-21b21cfc9e4830ee559f20aff270d151c2f1b44c.tar.gz
[build]: Parameterize X11-related man pages.
[build]: Parameterize X11-related man pages, so they don't get spuriously generated (and not cleaned) when building with X11 support disabled. * Makefile.am (.man): Fix logic nit: drop unnecessary removal of target before clobbering it with sed. * src/devices/xditview/xditview.am (GXDITVIEW_MAN1): Add new macro, expanding to nothing if `WITHOUT_X11` and to the target name otherwise. (man1_MANS): Append `GXDITVIEW_MAN1` expansion, not a literal. * src/devices/xditview/xditview.am (XTOTROFF_MAN1): Add new macro, expanding to nothing if `WITHOUT_X11` and to the target name otherwise. (man1_MANS): Append `XTOTROFF_MAN1` expansion, not a literal. * doc/doc.am (GROFF_MAN_PAGES1): Append foregoing expansions instead of literals.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index eba1309f0..f333a45c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -854,8 +854,7 @@ makevarescape=$(top_srcdir)/makevarescape.sed
SUFFIXES += .man
.man:
- $(AM_V_GEN)rm -f $@ \
- && $(MKDIR_P) `dirname $@` \
+ $(AM_V_GEN)$(MKDIR_P) `dirname $@` \
&& LC_ALL=C \
sed -e "s|[@]APPDEFDIR[@]|`echo $(appdefdir) | sed -f $(makevarescape)`|g" \
-e "s|[@]BINDIR[@]|`echo $(bindir) | sed -f $(makevarescape)`|g" \