summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2018-03-11 22:52:01 +0000
committerColin Watson <cjwatson@debian.org>2018-03-11 22:52:01 +0000
commit27cd0ce6758624a345265b31d20e31d0d9e869b2 (patch)
tree388d457946be2f8d050139a20f0c2eb93faaffec /Makefile.am
parent3b4b85baa3e2a252a6480b3cfb9cf984eff1b71a (diff)
downloadgroff-git-27cd0ce6758624a345265b31d20e31d0d9e869b2.tar.gz
Switch to Gnulib implementation of snprintf
This is more actively maintained, straightforward to integrate now that we have Gnulib integration, and simplifies groff's overall licensing. * bootstrap.conf (gnulib_modules): Add `snprintf' and `vsnprintf'. * configure.ac: Remove local checks for `snprintf' and `vsnprintf'. * Makefile.am: Remove various comments related to local checks for `snprintf' and `vsnprintf'. * src/include/lib.h: Remove declarations of `snprintf' and `vsnprintf'. * src/libs/libgroff/libgroff.am (EXTRA_DIST): Remove `src/libs/snprintf/snprintf.c'. * src/libs/snprintf/snprintf.c: Remove. * LICENSES: Remove section about `src/libs/snprintf/snprintf.c'. * MANIFEST: Remove entry for `src/libs/libxutil'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index cd86be722..7cc50f6f8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -397,14 +397,12 @@ man7dir=$(manroot)/man$(man7ext)
# HAVE_PUTENV if you have putenv()
# HAVE_RENAME if you have rename()
# HAVE_SETLOCALE if you have setlocale()
-# HAVE_SNPRINTF if you have snprintf()
# HAVE_STRCASECMP if you have strcasecmp()
# HAVE_STRNCASECMP if you have strncasecmp()
# HAVE_STRERROR if you have strerror()
# HAVE_STRSEP if you have strsep()
# HAVE_STRTOL if you have strtol()
# HAVE_SYMLINK if you have symlink()
-# HAVE_VSNPRINTF if you have vsnprintf()
#
# NEED_DECLARATION_GETTIMEOFTODAY
# if your C++ <sys/time.h> doesn't declare
@@ -415,8 +413,6 @@ man7dir=$(manroot)/man$(man7ext)
# NEED_DECLARATION_PUTENV if your C++ <stdlib.h> doesn't declare
# putenv()
# NEED_DECLARATION_RAND if your C++ <stdlib.h> doesn't declare rand()
-# NEED_DECLARATION_SNPRINTF if your C++ <stdio.h> doesn't declare
-# snprintf()
# NEED_DECLARATION_SRAND if your C++ <stdlib.h> doesn't declare srand()
# NEED_DECLARATION_STRCASECMP if your C++ <string.h> doesn't declare
# strcasecmp()
@@ -425,8 +421,6 @@ man7dir=$(manroot)/man$(man7ext)
# strncasecmp()
# NEED_DECLARATION_VFPRINTF if your C++ <stdio.h> doesn't declare
# vfprintf()
-# NEED_DECLARATION_VSNPRINTF if your C++ <stdio.h> doesn't declare
-# vsnprintf()
#
# HAVE_DECL_GETC_UNLOCKED if you have getc_unlocked()
# HAVE_DECL_SYS_SIGLIST if you have sys_siglist[]
@@ -461,12 +455,11 @@ man7dir=$(manroot)/man$(man7ext)
# Include
#
-# {fmod,getcwd,mkstemp,putenv,snprintf,strcasecmp,
+# {fmod,getcwd,mkstemp,putenv,strcasecmp,
# strerror,strncasecmp,strtol}.$(OBJEXT)
#
# LIBOBJS
# in LIBOBJS if your C library is missing the corresponding function.
-# vsnprintf is defined in the snprintf.$(OBJEXT) module.
# `CCC' is the compiler for C++ (.cpp) files.
CCC=@CXX@