summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-03-22 22:28:11 +1100
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-03-22 22:28:11 +1100
commit450179efd63dc4e5a6dee0fed52d8d4a442b8ae1 (patch)
treea4a87e79e8950f862834fb2e9ce01fbd8fb068ed /Makefile.am
parent773becd385fbcadb262edb2c1b49a290ddd37a31 (diff)
downloadgroff-git-450179efd63dc4e5a6dee0fed52d8d4a442b8ae1.tar.gz
Revert "Update .version file more aggressively."
This reverts commit c1bb33e5beec25b4059bca3cc4529b738ec486c7. This wasn't the right way to attack the problem; see <https://lists.gnu.org/archive/html/groff/2022-03/msg00051.html>.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 483efe46f..a4ef0e951 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -924,17 +924,8 @@ SUFFIXES += .man
# Version files - see script 'build-aux/git-gen-version'
EXTRA_DIST += $(top_srcdir)/.version
BUILT_SOURCES += $(top_srcdir)/.version
-# Regenerate a temporary version string file on every build, but update
-# the real version file's mtime only if its contents change.
-.PHONY: .version.tree
-.version.tree:
- @test -f $(distdir)/.tarball-verion || echo $(VERSION) > $@
-$(top_srcdir)/.version: .version.tree
- @if ! test -f $(distdir)/.tarball-version; then \
- test -f $@ || cp .version.tree $@; \
- cmp -s .version.tree $@ || cp .version.tree $@; \
- fi
-MOSTLYCLEANFILES += .version.tree
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version