summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-10-24 11:26:12 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-10-29 12:52:02 -0500
commit52350eb1debd7df586bbb478bc3faed80d79f8e0 (patch)
tree3e1ed8b4119b431c45d584e22e27dad85e795b9b /Makefile.am
parentc9d0b1a680b2a2a9553f440fe61d16e31068ea24 (diff)
downloadgroff-git-52350eb1debd7df586bbb478bc3faed80d79f8e0.tar.gz
[man pages]: Don't doc compat wrappers if unused.
[man pages]: Don't document macro package compatibility wrapper directory if it's not used. * Makefile.am (.man): Use sed to replace '@COMPATIBILITY_WRAPPERS@' in man page text with value of `compatibility_wrappers` shell variable. Document its purpose. * src/preproc/eqn/eqn.1.man (Description): * src/preproc/grn/grn.1.man (Options): * src/roff/groff/groff.1.man (Installation directories): * src/roff/troff/troff.1.man (Environment): Mention `@SYSTEMMACRODIR` only if `@COMPATIBILITY_WRAPPERS` expands to something other than "no" (it could be "yes" or "manual"). Thanks to Alexander Kanavin and Jeremy Puhlman for the report.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 007635c30..7561a9a18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -849,6 +849,10 @@ MOSTLYCLEANFILES += $(prefixexecbin_SCRIPTS) $(bin_SCRIPTS) \
# * For this target, no assurances about the good behavior of unusual
# characters in Makefile variables in other aspects of the groff build
# are offered.
+#
+# COMPATIBILITY_WRAPPERS is intended only for use in conditional
+# expressions in man pages (to see if the legacy macro package wrappers
+# feature is enabled) and not for expansion as formatted text.
makevarescape=$(top_srcdir)/makevarescape.sed
SUFFIXES += .man
@@ -858,6 +862,7 @@ SUFFIXES += .man
sed -e "s|[@]APPDEFDIR[@]|`echo $(appdefdir) | sed -f $(makevarescape)`|g" \
-e "s|[@]BINDIR[@]|`echo $(bindir) | sed -f $(makevarescape)`|g" \
-e "s|[@]COMMON_WORDS_FILE[@]|`echo $(common_words_file) | sed -f $(makevarescape)`|g" \
+ -e "s|[@]COMPATIBILITY_WRAPPERS[@]|$(compatibility_wrappers)|g" \
-e "s|[@]DATASUBDIR[@]|`echo $(datasubdir) | sed -f $(makevarescape)`|g" \
-e "s|[@]DEFAULT_INDEX[@]|`echo $(indexdir)/$(indexname) | sed -f $(makevarescape)`|g" \
-e "s|[@]DEFAULT_INDEX_NAME[@]|`echo $(indexname) | sed -f $(makevarescape)`|g" \