summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-02 19:53:12 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-03 10:43:12 -0500
commit52efd3457b307f4932bb864504e0fc01d7977a04 (patch)
tree8e93bea267a01c49e8feebb4a05062dfff5012e0 /Makefile.am
parentcc0bcaf240254e2104d6c9f25b2a15e557700a36 (diff)
downloadgroff-git-52efd3457b307f4932bb864504e0fc01d7977a04.tar.gz
Makefile.am: Stop manually handling "test-groff".
Per the GNU Automake manual, "If configure built it, then distclean should delete it." This is taken care of automatically if we don't interfere. * Makefile.am (BUILT_SOURCES, MOSTLYCLEANFILES): Drop "test-groff".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 76fb26d4a..9f6e2d8c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,8 +9,8 @@
# Software Foundation, either version 3 of the License, or
# (at your option) any later version.
#
-# groff is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# groff is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
# for more details.
#
@@ -690,9 +690,6 @@ include $(top_srcdir)/tmac/tmac.am
# src/roff/groff/groff.$(OBJEXT): defs.h)
BUILT_SOURCES += defs.h
-# Force generation of test-groff even though we don't ship it.
-BUILT_SOURCES += test-groff
-
.DELETE_ON_ERROR:
.PRECIOUS: $(TEST_SUITE_LOG)
@@ -823,8 +820,7 @@ EXTRA_DIST += \
MOSTLYCLEANFILES += $(prefixexecbin_SCRIPTS) $(bin_SCRIPTS) \
$(man1_MANS) $(man5_MANS) $(man7_MANS) \
- $(PREFIXMAN1) \
- test-groff
+ $(PREFIXMAN1)
# Suffix rule to build .1, .5 and .7 files from .1.man, .5.man and
# .7.man files. The brackets around the @ are used to prevent the