summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2017-11-19 22:51:29 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2017-11-19 22:51:29 -0500
commit62f8d5c5e2e4c5b075db68c85df1576ed19e1a9e (patch)
treecb513766005f50191c34baeb3c78c4359dd06a39 /Makefile.am
parent326d1f168f64e2c8e940ed6b82529b130ca377b0 (diff)
downloadgroff-git-62f8d5c5e2e4c5b075db68c85df1576ed19e1a9e.tar.gz
Makefile.am: Protect args to "tr" from globbing.
Prevents errors from tr during man page generation and possible incorrect program prefixing in those pages if, for example, some doofus has directories called "A", "B", ... hanging around in the build tree. Signed-off-by: G. Branden Robinson <g.branden.robinson@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 986fb30da..6232f552f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -878,7 +878,7 @@ SUFFIXES += .man
-e "s|[@]EXAMPLEDIR[@]|$(exampledir)|g" \
-e "s|[@]FONTDIR[@]|$(fontdir)|g" \
-e "s|[@]g[@]|$(g)|g" \
- -e "s![@]G[@]!`echo $(g) | tr [a-z] [A-Z]`!g" \
+ -e "s![@]G[@]!`echo $(g) | tr '[a-z]' '[A-Z]'`!g" \
-e "s|[@]HTMLDOCDIR[@]|$(htmldocdir)|g" \
-e "s|[@]INDEX_SUFFIX[@]|$(indexext)|g" \
-e "s|[@]LEGACYFONTDIR[@]|$(legacyfontdir)|g" \