summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2021-09-15 11:08:55 +1000
committerG. Branden Robinson <g.branden.robinson@gmail.com>2021-09-16 03:31:36 +1000
commit71e31708e66872ff0a6c3e915713e891c8bc0b3a (patch)
tree25c12288bd563d1e604de068b3602f2bf1ddaeb9 /Makefile.am
parent941e2b5d5f2b2528c718bbd49aff49403900b74e (diff)
downloadgroff-git-71e31708e66872ff0a6c3e915713e891c8bc0b3a.tar.gz
Makefile.am: Add `.DELETE_ON_ERROR` target.
* Makefile.am: Add `.DELETE_ON_ERROR` special target; both GNU and FreeBSD make(1)s support it so maybe it will be portable enough. This avoids, among other problems, a target appearing falsely up-to-date (often as an empty file) when the troff process generating it experiences an assertion failure.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9aea88945..bbbe5f6fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -719,6 +719,8 @@ BUILT_SOURCES += defs.h
# Force generation of test-groff even though we don't ship it.
BUILT_SOURCES += test-groff
+.DELETE_ON_ERROR:
+
# if there is a name prefix we install the man pages by hand
all: generate_man_files
install-data-hook: install-prefix-man