summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBertrand Garrigues <bertrand.garrigues@laposte.net>2014-09-07 12:41:50 +0200
committerBertrand Garrigues <bertrand.garrigues@laposte.net>2015-01-27 23:13:14 +0100
commit7eb6dac5aa1320dbc7c8ecfe0e149d565c8ca143 (patch)
tree8b23099b5ae86a6a5202353b1c5ca181f8c12356 /Makefile.am
parentfda6fac5a5d4fde6f32bd368bc00ea722c12309b (diff)
downloadgroff-git-7eb6dac5aa1320dbc7c8ecfe0e149d565c8ca143.tar.gz
Add contrib/hdtbl.
Build gnu.eps.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d467e33d..a756dc854 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -518,6 +518,8 @@ man7_MANS =
# for lex/yacc
AM_YFLAGS = -d -v
+SUFFIXES =
+
# tests launched by make check
check_SCRIPTS =
check_PROGRAMS =
@@ -527,6 +529,14 @@ AM_TESTS_ENVIRONMENT = \
abs_top_builddir=$(abs_top_builddir) \
export abs_top_srcdir abs_top_builddir;
+# Path to binaries and flags used by contribs and doc to generated doc.
+# These may be overridden if cross-compiling.
+GROFFBIN = $(abs_top_builddir)/groff
+GROFF_BIN_PATH = $(abs_top_builddir)
+PDFMOMBIN = $(abs_top_builddir)/pdfmom
+FFLAG=-F$(abs_top_builddir)/font -F$(abs_top_srcdir)/font
+TFLAG=-M$(abs_top_builddir)/tmac -M$(abs_top_srcdir)/tmac
+
# Non-recursive makefile system. See Automake manual '7.3 An
# Alternative Approach to Subdirectories'. We use a single Makefile.am
# that includes other .am files, rather than using SUBDIRS. Note that
@@ -545,6 +555,7 @@ include $(top_srcdir)/contrib/gpinyin/gpinyin.am
include $(top_srcdir)/contrib/grap2graph/grap2graph.am
include $(top_srcdir)/contrib/groff_filenames/groff_filenames.am
include $(top_srcdir)/contrib/groffer/groffer.am
+include $(top_srcdir)/contrib/hdtbl/hdtbl.am
include $(top_srcdir)/contrib/pic2graph/pic2graph.am
include $(top_srcdir)/font/devX100/devX100.am
include $(top_srcdir)/font/devX100-12/devX100-12.am
@@ -612,6 +623,17 @@ BUILT_SOURCES += defs.h
# possible
lib/localcharset.$(OBJEXT): lib/configmake.h
+# File used by contrib/hdtbl and contrib/pdfmark
+gnu.eps:
+ if test -f $(top_srcdir)/doc/gnu.eps; then \
+ cp $(top_srcdir)/doc/gnu.eps . ; \
+ elif test -f $(top_builddir)/doc/gnu.eps; then \
+ cp $(top_builddir)/doc/gnu.eps . ; \
+ else \
+ xpmtoppm $(top_srcdir)/doc/gnu.xpm | pnmdepth 15 \
+ | $(pnmtops_nosetpage) -noturn -rle >$@ ; \
+ fi
+
# directories specific to groff
uninstall-hook: uninstall_groffdirs
uninstall_groffdirs:
@@ -661,7 +683,7 @@ EXTRA_DIST += \
README.MinGW \
arch/djgpp
-MOSTLYCLEANFILES += $(man1_MANS) $(man5_MANS) $(man7_MANS) $(bin_SCRIPTS)
+MOSTLYCLEANFILES += $(man1_MANS) $(man5_MANS) $(man7_MANS) $(bin_SCRIPTS) gnu.eps
# Rule to build .man files. The brackets around the @ are used to prevent the
# substitution of the variable by automake.