summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2023-02-22 18:49:04 -0600
committerG. Branden Robinson <g.branden.robinson@gmail.com>2023-02-22 20:28:13 -0600
commit803ad5f7b341fe39cc471fbbcedccd0161503736 (patch)
treea262ee443e70637d4f10a9c8202ab40d923b8492 /Makefile.am
parent691fc701089875239485dd9e3e80d0735a4fd5e2 (diff)
downloadgroff-git-803ad5f7b341fe39cc471fbbcedccd0161503736.tar.gz
[doc]: Uninstall groff Texinfo in HTML better.
* Makefile.am (uninstall_groffdirs): Remove "html.mono" and "html.node" directories corresponding to HTML version of our Texinfo manual. * doc/doc.am (uninstall-html): Uninstall HTML version of our Texinfo manual more reliably.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0a37778cc..a5d8907f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -774,6 +774,12 @@ uninstall_groffdirs:
rmdir $(DESTDIR)$(exampledir); \
fi; \
if test -d $(DESTDIR)$(htmldocdir); then \
+ if test -d $(DESTDIR)$(htmldocdir)/groff.html.mono; then \
+ rmdir $(DESTDIR)$(htmldocdir)/groff.html.mono; \
+ fi; \
+ if test -d $(DESTDIR)$(htmldocdir)/groff.html.node; then \
+ rmdir $(DESTDIR)$(htmldocdir)/groff.html.node; \
+ fi; \
rmdir $(DESTDIR)$(htmldocdir); \
fi; \
rmdir $(DESTDIR)$(docdir); \