summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-06-01 16:46:52 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-06-03 04:01:12 -0500
commita47f786c83bac69332edd1a9be276b768bd0ff85 (patch)
tree2dc4b9565129fa6307dae3af7cbf1d017d93ee8e /Makefile.am
parent775ffb86589a0fd1e16d329ade6ebc81e859363a (diff)
downloadgroff-git-a47f786c83bac69332edd1a9be276b768bd0ff85.tar.gz
[build]: Rename variables and macros for clarity.
[build]: Rename shell variables and Autoconf/Automake macros of Boolean sense to have names more like logical predicates and avoid doofy "DONT" nomenclature. * m4/groff.m4 (GROFF_MAKE_RM): Rename shell variable `groff_is_rm_defined` to `groff_make_defines_rm` (purely for clarity; it already had a good name). (GROFF_MAKE_RM): Rename this... (GROFF_MAKE_DEFINES_RM): to this, to make parallelism obvious, and enabling... * configure.ac: ...rename of `MAKE_DONT_HAVE_RM` to `MAKE_DEFINES_RM` with sense of test reversed. Also interpolate `GROFF_MAKE_DEFINES_RM` instead of `GROFF_MAKE_RM`. This in turn enables... * Makefile.am: ...revision of conditional from `MAKE_DONT_HAVE_RM` to "!`MAKE_DEFINES_RM`".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 645b310e5..eba1309f0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -572,9 +572,8 @@ PDFMOMBIN = $(abs_top_builddir)/pdfmom
FFLAG=-F$(abs_top_builddir)/font -F$(abs_top_srcdir)/font
MFLAG=-M$(abs_top_builddir)/tmac -M$(abs_top_srcdir)/tmac
-# make builtin variable RM
-if MAKE_DONT_HAVE_RM
-RM = rm -f
+if !MAKE_DEFINES_RM
+RM=rm -f
endif
# 'VERSION' is generated by gnulib script git-version-gen, using the