summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-03-23 19:35:53 +1100
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-04-07 10:35:32 +1000
commita5af2f4d0f0064e96db78abb3d4675c2e15357da (patch)
tree57a3c3c286aceb65ffb0c15086940ea0544a7121 /Makefile.am
parente817cd13eb97b43d916bb8f5fa6ce0efa8a70590 (diff)
downloadgroff-git-a5af2f4d0f0064e96db78abb3d4675c2e15357da.tar.gz
Rename and drop some Make macros.
* Makefile.am: Rename `TFLAG` macro, which means "tmac flag", to `MFLAG`, because it expands to `-M` options to groff, not the `-T` option, which can be bewildering. * doc/doc.am (DOC_GROFF): Update expansion site. * contrib/hdtbl/hdtbl.am: Eliminate `HDTBL_TFLAG` and `HDTBL_PFLAG` Make macros; they were expanded in only one place. (HDTBLGROFF): Track rename of Make macro `TFLAG` to `MFLAG`. * contrib/mom/mom.am: Eliminate `MOM_TFLAG` and `MOM_PFLAG` Make macros; they were expanded in only one place. (MOMPDFMOM): Track rename of Make macro `TFLAG` to `MFLAG`. * contrib/pdfmark/pdfmark.am: Eliminate `PDFMARK_TFLAG` and `PDFMARK_PFLAG` Make macros; they were expanded in only one place. (PDFROFF): Track rename of Make macro `TFLAG` to `MFLAG`.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 30180d774..b96015687 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -596,9 +596,10 @@ endif
GROFFBIN = $(abs_top_builddir)/groff
GROFF_BIN_PATH = $(abs_top_builddir)
PDFMOMBIN = $(abs_top_builddir)/pdfmom
-# The second directories are needed for the case "cd build; ../configure".
+# Search for macro files and device/font description directories in
+# source _and_ build trees; some of each are generated.
FFLAG=-F$(abs_top_builddir)/font -F$(abs_top_srcdir)/font
-TFLAG=-M$(abs_top_builddir)/tmac -M$(abs_top_srcdir)/tmac
+MFLAG=-M$(abs_top_builddir)/tmac -M$(abs_top_srcdir)/tmac
# make builtin variable RM
if MAKE_DONT_HAVE_RM