summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2018-04-23 06:22:52 -0400
committerG. Branden Robinson <g.branden.robinson@gmail.com>2018-04-23 06:22:52 -0400
commita6c2217cd0a088b649257b87bea4299cbb1e90dd (patch)
tree5599a53ed4805c96faa1aa8f9956c04d22a38c21 /Makefile.am
parent3aae1e8939df0e86b3a46318cceb72e0eb774dc8 (diff)
downloadgroff-git-a6c2217cd0a088b649257b87bea4299cbb1e90dd.tar.gz
Document SHORT_VERSION where it is defined.
Leave a breadcrumb in Makefile.am since SHORT_VERSION is logically related but handled by a different layer of GNU Autotools. Further clarify what SHORT_VERSION actually expands to: not just the truncated revision number, but the whole version string _up to_ the truncation point. Signed-off-by: G. Branden Robinson <g.branden.robinson@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index bfea268f8..9de103f3b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -634,9 +634,7 @@ endif
# REVISION is the full revision given by git-version-gen, which can
# have non-alphanumeric symbols.
#
-# SHORT_VERSION (defined in configure.ac) contains only the number of
-# REVISION before the first '.', e.g. if REVISION is '3.real.434-5aafd'
-# then SHORT_VERSION is '3'.
+# Also see configure.ac for the related SHORT_VERSION macro.
MAJOR_VERSION =`echo $(VERSION) | sed 's/\([0-9]\+\)\.[0-9]\+.*/\1/'`
MINOR_VERSION =`echo $(VERSION) | sed 's/[0-9]\+\.\([0-9]\+\).*/\1/'`