summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2021-11-11 19:58:02 +1100
committerG. Branden Robinson <g.branden.robinson@gmail.com>2021-11-12 11:20:19 +1100
commitd79c3f3a4a19f7bf616a69558c4d3ce13690f441 (patch)
tree2f39fb82aeb3105e0e51f6b86ead16531202b144 /Makefile.am
parent8080238bcc2deeaa70103dd8d52b90bc123e8628 (diff)
downloadgroff-git-d79c3f3a4a19f7bf616a69558c4d3ce13690f441.tar.gz
Revamp Texinfo manual handling, part one.
Drop `BUILD_INFODOC` symbol. Ship manual in GNU Info, text, and HTML forms in distribution archive. * Makefile.am (MAINTAINERCLEANFILES): Initialize. (MOSTLYCLEANADD): Drop unused variable. * configure.ac: Drop `AM_CONDITIONAL([BUILD_INFODOC]...`. * doc/doc.am (EXTRA_DIST): Rearrange shipment of our Texinfo manual source files to precede all of the generated forms, for clarity. Drop all `BUILD_INFODOC` conditionals. Make `build_infodoc` phony target depend on plain text, GNU Info, and HTML forms of Texinfo manual unconditionally. Also drop unused variables `groffinfodir`, `groffpdfdir`, and `texi2dvi_missing`. (EXTRA_DIST, MAINTAINERCLEANFILES): Add Info form of manual. Drop glob pattern attempting to match the segments that `makeinfo` breaks it into. It isn't necessary for MAINTAINERCLEANFILES. (EXTRA_DIST, MAINTAINERCLEANFILES): Add text form of manual. (EXTRA_DIST, MAINTAINERCLEANFILES): Add HTML form of manual. (dist-hook): Depend on new (phony) target `dist-info-bits`. (dist-info-bits): Look for the info document in the build directory, then the source directory. (It could be in either place depending on whether the build from a Git working tree is being done in or out of a separate build directory.) When found, copy the segments to the assembly area for the distribution archive. (install_infodoc): Refactor. Remove any groff info files from the destination info directory using a shell glob directly instead of a partly redundant ls(1) command substitution. Similarly, use a shell glob to cp(1) the info files (including any matched segments) to the destination info directory before running `install-info`. (In this process I learned that `install-info` doesn't "install" anything; instead, it (de-)registers info files with their top-level catalog.) Tested by building: 1. from Git working tree with separate build directory; 2. from distribution archive w/ separate build directory (`distcheck`); 3. from distribution archive directly; 4. from Git working tree directly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e59b9ee48..741a333ea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -529,14 +529,15 @@ GROFF_V = $(GROFF_V_@AM_V@)
GROFF_V_ = $(GROFF_V_@AM_DEFAULT_V@)
GROFF_V_0 = @echo " GROFF " $@;
-# The following Automake variables will be overloaded by the various
-# .am files
+# The following Automake variables will be supplemented by the various
+# .am files.
bin_PROGRAMS =
nobase_bin_PROGRAMS =
bin_SCRIPTS =
dist_bin_SCRIPTS =
+# stuff that should be in distribution archives but not in source repo
+MAINTAINERCLEANFILES =
MOSTLYCLEANFILES =
-MOSTLYCLEANADD =
noinst_LIBRARIES =
BUILT_SOURCES =
CLEANFILES =