summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-06-01 14:59:11 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-06-03 04:00:45 -0500
commite1e305962ce4ecb4375189c2f8035d5cec7db7c5 (patch)
tree3684ecc7cfbfc158ac513dda4782b6f23a9b2fba /Makefile.am
parent4217304fed9cd062a5234e1211012432166f8420 (diff)
downloadgroff-git-e1e305962ce4ecb4375189c2f8035d5cec7db7c5.tar.gz
[build]: Rename APPRES* stuff to APPDEF*.
* configure.ac: * m4/groff.m4 (GROFF_APPDEFDIR_OPTION, GROFF_APPDEFDIR_DEFAULT, GROFF_APPDEFDIR_CHECK): Rename m4 macros and shell variable from "*appres*" to "*appdef*. Update interpolation sites. * configure.ac: * m4/groff.m4 (GROFF_APPDEFDIR_CHECK): Further rename this... (GROFF_APPDEFDIR_NOTICE): ...to this, for consistency with other post-report output macros. * Makefile.am: * PROBLEMS: * doc/automake.mom: * src/devices/xditview/xditview.am: Update interpolation sites of `appresdir`. * Makefile.am: * src/devices/xditview/gxditview.1.man: * src/roff/groff/groff.1.man: Update interpolation site of `APPRESDIR`. * NEWS: Add item.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 33c63f781..645b310e5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -195,8 +195,8 @@ systemtmacdir=$(libprogramdir)/site-tmac
# `localtmacdir' says where local files will be installed.
localtmacdir=$(dataprogramdir)/site-tmac
-# appresdir
-# `appresdir' says where to install the application resource file for
+# appdefdir
+# `appdefdir' says where to install the application defaults file for
# gxditview.
# glilypond_dir
@@ -858,7 +858,7 @@ SUFFIXES += .man
$(AM_V_GEN)rm -f $@ \
&& $(MKDIR_P) `dirname $@` \
&& LC_ALL=C \
- sed -e "s|[@]APPRESDIR[@]|`echo $(appresdir) | sed -f $(makevarescape)`|g" \
+ sed -e "s|[@]APPDEFDIR[@]|`echo $(appdefdir) | sed -f $(makevarescape)`|g" \
-e "s|[@]BINDIR[@]|`echo $(bindir) | sed -f $(makevarescape)`|g" \
-e "s|[@]COMMON_WORDS_FILE[@]|`echo $(common_words_file) | sed -f $(makevarescape)`|g" \
-e "s|[@]DATASUBDIR[@]|`echo $(datasubdir) | sed -f $(makevarescape)`|g" \