summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2023-02-15 17:48:32 -0600
committerG. Branden Robinson <g.branden.robinson@gmail.com>2023-02-15 23:48:24 -0600
commit195e17f2d9a42cebdd4aa6fc4ce4e65342c26181 (patch)
tree22896cbce4a49a7213e2d993bd2ccca53c6bd62f /configure.ac
parent9578e1f516b69833114bc35f8ed245952533f3e1 (diff)
downloadgroff-git-195e17f2d9a42cebdd4aa6fc4ce4e65342c26181.tar.gz
[build, gropdf]: Fix Savannah #63808 (3/3).
* configure.ac: Add Automake conditional, `HAVE_GHOSTSCRIPT`, so that we can populate the list of PDF device font tests dynamically. * font/devpdf/devpdf.am: Test availability of "basic" (PDF base 14) fonts (plus groff's "EURO") if either Ghostscript or URW fonts are available. Test availability of URW fonts (35) only if Ghostscript _and_ the URW fonts were found at configuration time. Test procedure for Savannah #63808: ./configure --prefix=$HOME make -j check make install make uninstall test -z "$(find $HOME/{bin,lib,share} -type f)" && echo clean make distclean Configurations and test results (total/pass/skip/xfail) ------------------------------------------------------- without gs, without URW fonts: 161/152/7/2 with gs, without URW fonts: 162/155/5/2 without gs, with URW fonts: 162/153/7/2 with gs, with URW fonts: 163/156/5/2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6cd11fdda..41745b7be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -204,6 +204,8 @@ AM_CONDITIONAL([USE_GROHTML], [test "$use_grohtml" = yes])
AM_CONDITIONAL([USE_GROPDF], [test "$use_gropdf" = yes])
AM_CONDITIONAL([USE_GROFF_ALLOCATOR],
[test "$groff_use_own_allocator" = yes])
+AM_CONDITIONAL([HAVE_GHOSTSCRIPT], [test "$GHOSTSCRIPT" != no \
+ && test "$GHOSTSCRIPT" != missing])
AM_CONDITIONAL([HAVE_URW_FONTS], [test "$groff_have_urw_fonts" = yes ])
AM_CONDITIONAL([HAVE_PDFTOOLS], [test "$groff_have_pdftools" = yes ])
AM_CONDITIONAL([HAVE_TEXI2DVI], [test "$groff_have_texi2dvi" = yes ])